System performance has returned to normal. Earlier today, Swyft experienced degraded performance due to a global AWS outage that affected several connected integrations. AWS services have since recovered, and all Swyft integrations are now operating normally.
Posted Oct 20, 2025 - 15:07 CDT
Monitoring
We’re currently experiencing degraded performance due to a global AWS outage affecting several of Swyft’s connected integrations. This may result in delays or intermittent failures when syncing data between Swyft and external systems (e.g., Salesforce, HubSpot, Slack, and others).
Our infrastructure remains operational, but performance is impacted while dependent services recover. We are actively monitoring AWS’s status and will provide updates as more information becomes available.
What you can expect: • Slower or failed syncs between Swyft and external integrations • Possible delays in meeting or workflow processing • No data loss is expected
We’ll share another update as soon as AWS reports recovery progress or once Swyft performance stabilizes.
Thank you for your patience and understanding. — The Swyft Engineering Team
Posted Oct 20, 2025 - 10:23 CDT
This incident affected: Dashboard and Backend System.